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Reconstruccion de la nube de puntos con
MeshLab

Introduccion a MeshLab!

MeshLab es una herramienta avanzada de procesamiento de mallas 3D y un sistema de software
muy utilizado en campos mas técnicos de desarrollo 3D y manejo de datos. MeshLab es librey es
software de cédigo abierto, bajo la licencia GNU (GPL). Se utiliza como un programa completo y
como biblioteca para otros softwares.

MeshLab ha sido desarrollado por el centro de investigaciéon ISTI-CNR; inicialmente, MeshLab
fue creado como un trabajo de curso en la Universidad de Pisa a finales de 2005. Se trata de un
sistema orientado a la transformacion de modelos 3D no estructurados tipicos que se presentan
en ladigitalizacién en 3D de tuberias. MeshLab estd orientado a la gestion y procesamiento de
grandes mallas no estructuradas y proporciona un conjunto de herramientas para la edicion,
limpieza, reparacion, inspeccion, representacion y conversién de este tipo de mallas.

Los filtros de limpieza automatica de mallas incluyen: la eliminacion de duplicados, vértices
sin referencias, aristas no multiples, caras y vértices nulos. Las herramientas de remallado
se basan en la medida del error cuadratico medio, superficies de subdivision y algoritmos de
reconstruccion de la superficie de las nubes de puntos en funcion de la técnica “ball-pivoting” y en
el enfoque de reconstruccion de la superficie de Poisson. Para la eliminacion de ruido, MeshLab
posee varios tipos de filtros de suavizado y herramientas para el analisis y visualizacién de la
curvatura.

Incluye una herramienta para el registro de los mapas de distribucién multiples basados en
el punto mas cercano usando un algoritmo iterativo. MeshLab también incluye un sistema
interactivo que permite cambiar de forma interactiva el color de una malla para definir
selecciones y para suavizar directamente caracteristicas provocadas por el ruido.

MeshlLab esté disponible para la mayoria de plataformas, incluyendo Windows, Linux, Mac OS X,
y conuna funcionalidad reducida paraiOS y Android. El sistema es compatible con los siguientes
formatos, tanto de entrada como de salida: PLY, STL, OFF, OBJ, 3DS, VRML 2.0, U3D, X3D y
COLLADA.

Meshlab también permite importar nubes de puntos reconstruidas usando Photosynth.

Abrir ficheros PLY en MeshLab

Abre la nube de puntos en MeshlLab. Esta nube de puntos tiene la extension “ply”.

Abrir MeshLab: en la pantalla principal de la aplicacion puedes ver un menu en la parte superior,
debajo de este una barra de tareas v, por ultimo, un visualizador 3D que ocupa la mayor parte
de laventana.

1 Introduccién a MeshLab http:/enwikipedia.org/wiki/Meshlab (27 Febrero 2015)



http://en.wikipedia.org/wiki/PLY_(file_format)
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Importar archivo Mesh: Archivo > Importar Mesh (File > Import Mesh).

[0 [P Fd BN 0]

Elegir el modelo de puntos (.ply): en la ventana Importar Mesh selecciona el archivo de la nube
de puntos que quieras importar y pulsa el boton Abrir.

El software de escaneo Horus guarda por defecto las nubes de puntos como archivos con
formato “ply”

Visualizacién de la nube de puntos: una vez importado el archivo, se visualiza en 3D Ia
representacion en el espacio de dicha nube.

Sila nube de puntos es resultado de un escaneo con textura, la nube de puntos aparece con los
colores de dicho escaneo.

Si, por el contrario, es resultado de un escaneo sin textura se muestran todos los puntos del color
elegido a la hora del escaneo.
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Limpieza de la nube de puntos

Es posible que la nube de puntos no sea perfecta y contenga puntos de ruido o, simplemente,
puntos que no quieres que formen parte del modelo final. MeshlLab permite seleccionar vy
eliminar puntos de la nube.

Herramienta Seleccionar vértices: en la barra de tareas superior esté la herramienta Seleccionar
vértices (Select vertex) que permite seleccionar puntos situados en un espacio de tres dimensiones
conun rectangulo, que es una figura de dos dimensiones.

Seleccionar los vértices: puedes afiadir mas puntos a la seleccién pulsando la tecla Control y
manteniendo pulsado el botén izquierdo del ratdn mientras desplazas el cursor. Junto al cursor
aparece el simbolo “+”.

También puedes deseleccionar los puntos que hayas seleccionado anteriormente pulsando la
tecla Shift y manteniendo pulsado mientras se desplaza el botén izquierdo del ratén. Junto al
cursor aparecera el simbolo “’ Manteniendo pulsado el botén izquierdo del ratony desplazando
el cursor por la pantalla puedes seleccionar los vértices. Los vértices seleccionados se muestran
en color rojo.

Unavez seleccionados los vértices que quieres eliminar, deja de pulsar el botonizquierdo del ratén.

Eliminar los vértices no deseados: una vez seleccionados los vértices que quieres eliminar, pulsa
en Eliminar vértices seleccionados (Delete Selected Vertex) situada en la barra de herramientas.

ax
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Nube de puntos limpia: es importante que la nube de puntos que quieres reconstruir no tenga
mucho ruido. El algoritmo de reconstruccion filtra parte del ruido pero si la nube tiene muchos
puntos que no pertenecen al modelo, el resultado de la reconstrucciéon puede no ser preciso.

Ty
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Procesado de la nube de puntos

Para procesar una nube de puntos es necesario crear las normales del objeto:

Menu calcular normales: Filtros > Normales, Curvaturas y Distorsion > Calcular normales para
grupos de puntos (Filters > Normals, Curvatures and Distortion > Compute normals for point sets).

Ventana calcular normales: en esta ventana tienes que modificar el valor del Niimero de vecinos
(Neighbour number) que representa el nimero de puntos cercanos que debe tener uno de ellos
para calcular la normal.

Se recomienda utilizar 10, 50 0 100 como valor inicial. Es posible que tengas que modificar este
valor més adelante. Se recomienda mantener el resto de valores por defecto.

Una vez modificado el parametro, pulsa el botén Aplicar (Apply). El programa tarda unos
segundos en calcular las normales. Cuando termine, pulsa el botén Cerrar (Close).

10 @ ¢ NS ¢ /HMEERLIEED XXX
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Mostrar las normales: por lo general, las mejores reconstrucciones se consiguen cuando el
sentido de las normales es hacia fuera del objeto.

Para mostrar las normales pulsa en la pestafa Render > Mostrar Normales/Curvatura (Render >
Show Normals/Curvature).

Para ocultarlas, vuelve a pulsar en la misma pestana.

(e
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Ver las normales: las normales aparecen representadas por lineas de color azul sobre la
superficie de la nube de puntos.

No siempre se consigue que todas las normales estén situadas hacia el exterior del objeto.
La geometria, la densidad de la nube y el nimero de vecinos escogido a la hora de calcular las
normales influyen en este resultado.

En caso de que las normales no estén dirigidas hacia el exterior del objeto, es recomendable
recalcular las normales variando el nimero de vecinos hasta dar con un resultado vélido.

¢ - PH® ¢ /B TR i EED XXX

Reconstruccion del objeto a partir de la nube de
puntos

A partir de las normales generadas en el apartado anterior, procede a la reconstruccién del
objeto.

Menli filtro de reconstruccion: Filtros > Remesh, Simplificacion y Reconstruccion > Reconstruccion
de superficie: Poisson (Filters > Remeshing, Simplification and Reconstruction > Surface
Reconstruction: Poisson).
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Ventana del filtro de reconstruccion: en esta ventana puedes modificar los valores de Octantes
(Octree Depth) y Division de la solucién (Solver Divide).

Las configuraciones recomendadas para estos parametros son valores entre 6 y 12 (si tu
ordenador no es muy potente es recomendable fijar el maximo en 11). Es recomendable
conservar el resto de valores por defecto.

A medida que aumenta el valor de estas variables, aumenta la precision del modelo final, pero
también el tiempo de procesado.

Una vez modificados los valores, pulsa en el botén Aplicar (Apply). El tiempo de procesado
puede variar desde unos segundos hasta bastantes minutos. Es posible que durante este tiempo
aparezca la ventana “No responde”. A menos que aparezca una ventana emergente, no debes
cerrar la ventana. El tiempo de procesado depende de las caracteristicas del ordenador donde
se estd ejecutando el programa. No es recomendable utilizar ordenadores con especificaciones
bajas para el procesado de nubes de puntos.

Una vez termine el proceso de reconstruccion, pulsa el botén Cerrar (Close).

I @ ¢ -@le & /B iSa. i f8d XXX

Visualizacion del resultado de la reconstruccion

Una vez terminada la reconstruccion, las capas de la nube de puntos y del objeto reconstruido
estan solapadas. Para visualizar solamente el resultado de la reconstruccion, oculta la capa de
la nube de puntos.
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Ventana de visualizacién de capas: para mostrar la ventana de visualizacion de capas pulsa en
Vista > Mostrar Didlogo de Capas (View > Show Layer Dialog).

Ocultar capa de la nube de puntos: el icono con un dibujo de un ojo que se encuentra a la
izquierda del nombre de cada capa, sirve para mostrar la visibilidad de cada capa. Si pulsas sobre
él, puedes ocultarla o mostrarla.

Se ocultalacapa que contiene la nube de puntos para una mejor visualizacion de la reconstruccion.

Guardado del resultado de la reconstruccion

Menu Exportar Mesh: |a opcidon para exportar el Mesh estd en Archivo > Exportar Mesh...
(File > Export Mesh...).




HORUS |

10

GUIA DE POST-PROCESADO DE LA NUBE DE PUNTOS
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Ventana de exportacion: selecciona la opcion de exportar a un archivo en formato STL, navega
hasta la carpeta donde quieras guardar el archivo y pulsa en el boton Guardar (Save).

Elige STL porque es un formato de archivo que los programas de impresion 3D de laminado pueden
abrir correctamente. Si deseas exportar el archivo para otros usos puedes elegir otro formato.

LR
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Unir nubes de puntos con MeshLab

A veces, debido a la geometria del objeto que se escanea o el nimero de laseres utilizados en
el escaneo, las nubes de puntos estan incompletas. La solucion es volver a escanear el objeto
colocandolo en otra posicion de la plataforma o utilizando otro laser, y después unir las nubes
de puntos. Para explicar este método se utilizan dos nubes de puntos, pero este proceso puede
hacerse con todas las nubes de puntos que quieras y el procedimiento serad siempre el mismo.

Abre los archivos “ply” correspondientes a las nubes de puntos de ambos escaneos.

e

En el visualizador de las capas (Ctrl + L), selecciona una capa vy calcula sus normales. Una vez
terminado el proceso haz lo mismo para la otra capa. Comprueba de forma grafica (visualizando
las normales de cada capa) que se han calculado correctamente.

Herramienta Alinear: la herramienta Alinear (Align) se encuentra en el men Editar (Edit).
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Panel Alinear: en el panel de la herramienta Alinear pulsa sobre la primera capay después en el
botén Pegar Mesh Aqui (Glue Here Mesh). Esta accién fijala primera nube de puntos en el espacio.

Después, selecciona la segunda capay pulsa sobre el boton Pegado basado en puntos (Point Based
Glueing), que abre una nueva ventana de la herramienta.

En esta ventana puedes orientar las nubes de puntos para hacer méas sencilla la alineacion de
los puntos. A continuacion, selecciona al menos tres puntos de una de las nubes de puntos y los
puntos a los que corresponden en la otra nube. La seleccion se realiza haciendo doble clic conel
botén derecho del ratdon sobre la nube de puntos.

Los puntos seleccionados aparecen de manera numerada para no dar lugar a error. En caso de
seleccionar un punto no véalido pulsa el botén Cancelar (Cancel) y vuelve a abrir esta ventana,
puesto que no existe la opcidon Deshacer.

Una vez hayas seleccionado los puntos correspondientes en ambas nubes pulsa el botén OK.

& Meshlab Blbie 1 o |
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Comprueba que, tras el paso anterior, las nubes de puntos estan alineadas. En caso de que no
estén bien alineadas, repite el paso anterior hasta que lo estén.

Para completar la alineacion pulsa sobre el botén Procesar (Process).
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Visualizacion de las nubes de puntos alineadas: puedes comprobar a simple vista el resultado
de la alineacion, el detalle mejoray la falta de puntos se corrige.

Unir nubes de puntos

Las nubes de puntos alineadas en el paso anterior no estan unidas, esto es, son nubes de puntos
distintas.

Es necesario unir ambas para poder realizar la reconstruccion del objeto.

Menu Unir capas

Unir capas visibles: la herramienta para unir las capas visibles se encuentra en la pestana Filtros
> Capa Mesh > Unir capas visibles (Filters > Mesh Layer > Flatten Visible Layers).

aw
an

Ventana Unir capas visibles: en esta ventana selecciona la opcidon Mantener vértices no
referenciados (Keep unreferenced vertices).

Y pulsa el botén Aplicar (Apply).

12
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Elresultado de unir las nubes de puntos es una nueva nube de puntos con mejor resolucion.

Una vez unidas las capas conviene recalcular las normales de la nueva nube de puntos. Para
obtener el modelo reconstruido procede de la misma manera explicada anteriormente.

Suavizar resultados de la reconstruccion

Cuando se reconstruyen objetos a partir de una nube de puntos puede ocurrir que el resultado
no sea completamente preciso. La falta de puntos afecta a la reconstruccion y no siempre puede
solucionarse esta carencia de puntos uniendo varias nubes de puntos.

Un ejemplo de este tipo de objetos puede ser el objeto utilizado en las primeras secciones, la
base del objeto no puede ser escaneada (ya que se apoya sobre ella) y la parte superior no tiene
puntos debido a su geometria.

No obstante, el algoritmo de reconstruccion trata siempre de cerrar las caras, para obtener una
superficie cerrada.

mm S - OHS -« /W iEh

Parte superior antes de la reconstruccion Parte inferior antes de la reconstruccion

Parte superior después de la reconstruccién Parte inferior después de la reconstruccién

Como puedes observar, el proceso de reconstruccion ha cerrado la parte superior y la parte
inferior, pero el resultado es mejorable.

Para mejorar este resultado, se pueden aplicar filtros de suavizado a las zonas que han sido mal
reconstruidas.
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Herramienta de seleccién de caras: esta herramienta funciona de la misma manera que la de
Seleccion de vértices, la Unica diferencia es que esta selecciona caras.

‘Cumtatlie Posson mueh
s 74558 (£0013)
Faces 43098 (549096

Seleccién de caras erréneas: al igual que con la otra herramienta, pulsa el botén derecho del
ratony desplaza el cursor para seleccionar las caras que quieres suavizar.

Esimportante recordar que no tienes que seleccionar solo las caras que se ven, también las que
se encuentran dentro del rectangulo y no son visibles desde la perspectiva actual.

Para deseleccionar las caras que has seleccionado pero no quieres modificar, pulsa de nuevo
sobre la herramienta de Seleccion de caras en |a barra de tareas, con el botén izquierdo del raton.
Cambiala posicion del objeto para visualizar las caras que quieres deseleccionar, cuando tengas
el objeto colocado en la posicidon deseada pulsa otra vez sobre la herramienta de seleccion de
caras. Durante este proceso las caras seleccionadas anteriormente han mantenido la seleccion.
Por ultimo, pulsa la tecla Shift mientras desplazas el cursor sobre las caras que no quieres
modificar.

Cuando solo estén seleccionadas las caras que quieren suavizarse, pulsa sobre la herramienta
Seleccién de caras. Las caras quedan seleccionadas.

LR
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Men Filtro de suavizado: a las caras seleccionadas se les aplica el filtro de Suavizado Taubin
(Taubin Smooth), que se encuentra en la pestana Filtros > Suavizado, Fairing y Deformacién >
Suavizado Taubin (Filters > Smoothing, Fairing and Deformation > Taubin Smooth).
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Filtro de suavizado Taubin: en la ventana del Filtro de suavizado Taubin se pueden modificar
varios pardmetros.

Es recomendable activar la casilla Previsualizacion (Preview) para ver a tiempo real el efecto que
tienen las modificaciones de los parametros sobre el objeto.

También se recomienda mantener el valor de Lamda por defecto. En el ejemplo se ha modificado
el pardmetro Muy los Pasos de suavizado (Smoothing Steps).

Dependiendo del error de las caras cometido en la reconstruccién, los pardmetros seran
diferentes por lo que se recomienda probar con distintos valores hasta dar con el adecuado.

Una vez ajustados los pardametros deseados pulsa sobre el boton Aplicar (Apply).

El resultado de aplicar el filtro de suavizado es notable. Aplicar el filtro de suavizado a todas
las caras de un objeto provoca una disminucion en el detalle, por lo que es importante aplicarlo
Unicamente a las caras erroneas.

weoeomic 9D

Parte superior tras aplicar filtro de suavizado Parte inferior tras aplicar filtro de suavizado
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Reconstruccion de la nube de puntos con
CloudCompare

Introduccion a CloudCompare?

CloudCompare es un programa de procesamiento de nubes de puntos (como las obtenidas con
un escaner 3D). También procesa mallas triangulares e imagenes calibradas.

Este software fue creado durante una colaboracion entre Telecom ParisTech y la division de
[+D de la EDF, el proyecto CloudCompare comenzd en 2003 con la tesis doctoral de Daniel
Girardeau-Montaut en Deteccion de cambios en datos geométricos en 3D. En ese momento,
su objetivo principal era detectar rapidamente cambios en las nubes de puntos de alta densidad
adquiridos con escaneres laser en instalaciones industriales (como las centrales eléctricas) o en
sitios de construccién. Posteriormente evoluciond hacia un software mas general y avanzado
de procesamiento de datos 3D. Ahora es un proyecto de cddigo abierto independiente y un
software libre.

CloudCompare proporciona un conjunto de herramientas basicas para la edicién y renderizado
de nubes de puntos y mallas triangulares. También ofrece varios algoritmos de procesamiento
avanzados, para llevar a cabo tareas como: proyecciones, registros, calculos de distancia,
estadisticas, segmentacion o estimacion de caracteristicas geométricas.

CloudCompare esta disponible en plataformas Windows, Linux y Mac OS X, tanto para
arquitecturas de 32 como de 64 bits. Esta desarrollado en C ++ con Qt.

Abrir ficheros PLY en CloudCompare

Abre la nube de puntos en CloudCompare que tendré la extension “ply”.

Abrir CloudCompare: en la pantalla principal hay un ment en la parte superior y debajo una
barra de tareas, a laizquierda una barra de herramientas, en la parte inferior hay una consolay,
por ultimo, un visualizador 3D.

2 Introduccion a CloudCompare http://en.wikipedia.org/wiki/CloudCompare (27 Febrero 2015)
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Importar archivo Mesh: abre un archivo en Archivo > Abrir (File > Open).

Elegir el modelo de puntos (.ply): en la ventana Abrir puedes seleccionar el archivo de la nube
de puntos que quieras procesar. Una vez seleccionado, pulsa Abrir.

El software de escaneo Horus guarda por defecto las nubes de puntos como archivos con
formato “ply”, por lo que tienes que seleccionar este tipo de archivos en el ment desplegable.

Cloudcompare v2.6.0 [64 bits] - [0 View 1]

Propiedades para archivos “ply”: esta ventana aparece cuando se abre un fichero “ply” que
muestra opciones de configuracion avanzadas. Se recomienda mantener los valores por defecto.
Para continuar con la apertura del archivo, pulsa Aplicar (Apply).

Ply File Open
Type |PLY_LITTLE_ENDIAN
Elements 1 Properties 6
Point X vertex - x [PLY_FLOAT]
Point Y vertex - y [PLY_FLOAT]
Point Z vertex - z [PLY_FLOAT] v
Red vertex - red [PLY_UCHAR]
Green vertex - green [PLY_UCHAR]
Blue vertex - blue [PLY_UCHAR]
Intensity None
N None
Ny None
Nz None
Faces None
Texture coordinates  None
Scalar None
Add Scalar field
Apply Apply all Cancel
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Visualizacion de la nube de puntos: una vez importado el archivo de la nube de puntos puedes
ver en el visualizador 3D la representacion en el espacio de dicha nube.

Sila nube de puntos es resultado de un escaneo con textura, visualizaras la nube de puntos con
los colores de dicho escaneo.

Si, por el contrario, es resultado de un escaneo sin textura se mostraran todos los puntos del
color elegido a la hora del escaneo.

Limpieza de la nube de puntos

Es posible que la nube de puntos no sea perfecta y contenga puntos de ruido o, simplemente,
puntos que no deseas que formen parte del modelo final. CloudCompare permite seleccionary
eliminar puntos de la nube.

Herramienta Segmentar: el primer paso para limpiar la nube de puntos es seleccionar la capa
que la contiene. Paraello, pulsa sobre la capa con el sobrenombre Cloud en el &rbol de ficheros
situado en el lateral izquierdo.

A continuacion, pulsa sobre la herramienta Segmentar (Segment) situada en la barra de tareas.

Esta herramienta permite seleccionar puntos situados en un espacio de tres dimensiones con
un poligono, que es una figura de dos dimensiones. ; Como? Puedes pensar en esta herramienta
como una caja en la que puedes modificar una de las caras, que selecciona desde el frente hasta
el fondo todos los puntos que estan dentro de esta.
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Pausa y posicién: en ocasiones, los puntos que se quieren eliminar no se encuentran visibles
desde el punto de vista inicial. La herramienta Segmentar se compone de varias acciones:
Pausa (Pause), Seleccion (Selection), Segmentar hacia dentro (Segment in), Segmentar hacia afuera
(Segment Out), Deshacer (Clear segmentation), Confirmar segmentacién (Confirm segmentation),
Borrar puntos ocultos (Confirm and delete hidden points) y Cancelar (Cancel).

La accion Pausa permite orientar la nube de puntos libremente sin seleccionar ningn punto.
Unavez tengas la nube en la posicion deseada, pulsa de nuevo la accidon Pausa para comenzar la
seleccion de los puntos.

v & @ Toram - Clovs

Segmentacién hacia afuera: la accion de Seleccion permite seleccionar los puntos con ayuda
de un poligono en el que se marcan los vértices, o bien con ayuda de un rectangulo en el que se
definen los lados.

Para utilizar la Seleccién poligonal haz un primer clic con el botén izquierdo del ratén donde
quieras colocar el primer vértice, un segundo clic donde quieras colocar el segundo vértice y asi
sucesivamente. Cuando hayas definido el poligono de seleccién pulsa el botén derecho del ratén.
A continuacion, pulsa sobre una de las dos acciones de segmentacion.

Hay dos tipos de segmentacion: Hacia afuera o Hacia dentro.

La segmentacion hacia afuera mantiene visibles los puntos que no estan dentro del poligono de
selecciony mueve los que estadn dentro a otra capa oculta.
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Reconstruccion de la nube de puntos con CloudCompare

Segmentacién hacia dentro: por contra, la Segmentacion hacia dentro mantiene visibles los
puntos que se encuentren dentro del poligono de seleccion y mueve los que estan fuera a otra
capa oculta.

(1708
[17:06:
[17-08:58] [VBO) VBOL)

Limpieza de nube de puntos: al pulsar sobre la accion de segmentacion, los puntos no deseados
dejardn de visualizarse.

Para terminar la segmentacion hay dos opciones posibles. La primera es pulsar sobre Borrar
puntos ocultos, esta accion eliminara los puntos que se hayan seleccionado previamente y estén
ocultos.

La segunda opcidn es pulsar sobre la accidon Confirmar segmentacion, esta accion separara en
diferentes capas los puntos no deseados y los que se quieren mantener.

- B & Toun - Clovi

0
[17-08:58] NB0) vBCIs) ¢

Eliminando capa de puntos no deseados: en el caso de que hayas seleccionado la opcién de
Confirmar segmentacion se recomienda eliminar la capa de puntos no deseados. Paraello, pulsa
sobre la capa que los contieney, a continuacion, pulsa con el botdn derecho del ratén sobre ella.
En el menu desplegable pulsa sobre Eliminar (Delete).
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Resultado de la limpieza de la nube de puntos: una vez se ha limpiado la nube de puntos, puedes
observar como las aristas amarillas de la caja que contiene la nube de puntos se ajusta mucho
mas que al inicio.

Esimportante realizar lalimpieza de la nube de puntos si quieres obtener los mejores resultados.

(1708258 vBo) v
(17:09:53) (vBO) Ve
[17:09:53] B Ve

(10,87 Ma - 160.900K of
00 My = 100,00 of po

Procesado de la nube de puntos

Para procesar una nube de puntos es necesario crear las normales del objeto:

Menu calcular normales: el primer paso es seleccionar la capa que contiene la nube de puntos
de la que quieres calcular las normales.

A continuacion, pulsa sobre la pestana Editar > Normales > Calcular (Edit > Normals > Compute).

Ventana calcular normales: en esta ventana tienesque modificar el pardmetro de la orientacién.
Se recomienda utilizar la orientacién Barycenter y mantener el resto de valores por defecto.

Una vez modificado el pardmetro, pulsa el boton Aplicar (Apply). El programa tarda unos
segundos en calcular las normales. Cuando termine, pulsa el botén Cerrar (Close).
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Mostrar las normales: por defecto, la visualizacion de las normales estd activada. Si no lo estd,
puedes hacerlo pulsando con el botdn derecho sobre la capa de la que se han calculado las
normales y haciendo clic sobre la pestafa Mostrar Normales (Toggle normals). Para ocultarlas
vuelve a pulsar en la misma pestana.

Parauna reconstruccion correcta, las normales tienen que estar dirigidas hacia afuera de la pieza,
es decir, el objeto se vera de color negro (el color de las normales). En caso de que el exterior
del objeto no se vea de color negro, pero el interior si serd debido a que las normales han sido
calculadas del revés.

En las pruebas realizadas se elige Barycenter como parametro de orientacion, las normales a
zxvc siempre han sido calculadas hacia afuera del objeto. No obstante, si se da el caso de que
son calculadas del revés pueden invertirse pulsando sobre la pestafa Editar > Normales > Invertir
(Edit > Normals > Invert).

Reconstruccion del objeto a partir de la nube
de puntos

A partir de las normales generadas en el apartado anterior, se procede a la reconstruccion del
objeto.

Menu herramienta de reconstruccién: la herramienta de reconstruccion de nubes de puntos
estd situada en la pestaia Pluggins > Reconstruccion de Superficie Poisson (Pluggins > Poison
Surface Reconstruction).

Pulsando sobre ella se abre la ventana de la herramienta.
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Reconstruccion de la nube de puntos con CloudCompare

Ventana de la herramienta de reconstruccién: en esta ventana se puede modificar el valor de
Octantes (Octree depth).

Las configuraciones recomendadas para este parametro son valores entre 6y 12 (si tu ordenador
no es muy potente se recomienda fijar el maximo en 11). Se recomienda conservar el resto de
valores por defecto.

A medida que aumenta el valor de esta variable, aumenta la precision del modelo final, pero
también el tiempo de procesado.

Una vez modificado este valor, se pulsa en el botdn OK. El tiempo de procesado puede
variar desde unos segundos hasta bastantes minutos y depende de las caracteristicas del
ordenador donde se esté ejecutando el programa. No se recomienda utilizar ordenadores con
especificaciones bajas para el procesado de nubes de puntos.

Peissen Surface Reconstruction

Octree depth 8

Advanced

samples per node | 1.00
full depth 5

point weight 4.00

Densty
output density as SF

Density is useful to reduce the output
mesh o fit as much as possible
to the input point cloud. Use the SF
“min dispiay ue until the
remaining part of the mesh suits your

Cancel OK

Importar colores de la nube de puntos a la reconstruccion: unavez el proceso de reconstruccion
ha terminado, aparece una ventana que pregunta si deseas o no importar los colores de la nube
de puntos alareconstruccion.

En caso de haber realizado un escaneo con textura, o uno sin textura peroquieres conservar el
color de la nube de puntos, pulsa sobre el botdn Si (Yes). El proceso de importar el color puede
tardar desde unos segundos hasta unos minutos, dependiendo de la cantidad de puntos de |a
nube y de las caracteristicas del ordenador donde se esta procesando.

En caso de no querer importar el color pulsa el botédn No.

CloudCompas 260 (64 ] - (10 Vir 1]
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Reconstruccion de la nube de puntos con CloudCompare

Guardado del resultado de la reconstruccion

MenU Guardar: para guardar el resultado de la reconstruccién es importante seleccionar la capa
marcada como Mesh. A continuacion, pulsa sobre la pestafa Archivo > Guardar (File > Save).

Ventana de guardado: selecciona la opcidon Exportar a un archivo en formato STL, navega en la
ventana hasta la carpeta donde quieras guardar el archivo y pulsa en el botén Guardar.

Elige STL porque es un formato de archivo que los programas de impresion 3D de laminado
pueden abrir correctamente. Si deseas exportar el archivo para otros usos, puedes elegir el
formato mas conveniente.

Unir nubes de puntos con CloudCompare

Aveces, debido a la geometria del objeto que se escanea o al nimero de laseres utilizados enel
escaneo, las nubes de puntos estan incompletas. La solucion a este problema es volver a escanear
el objeto colocandolo en otra posicidn de la plataforma o utilizando otro laser, y después unir las
nubes de puntos. Para explicar este método se utilizan dos nubes de puntos, pero este proceso
puede hacerse con todas las nubes de puntos que quieras y el procedimiento es siempre el
mismo.

Abre los archivos “ply” correspondientes a las nubes de puntos de ambos escaneos.
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Herramienta Alinear: selecciona las capas que quieres alinear y pulsar sobre la herramienta
Alinear (Align) que se encuentra en la barra de tareas.

(1743
[17:43:08) (0] Fie
(174308 [vBo) Ve

Tras pulsar sobre la herramienta aparece una ventana que muestra la capa que se considera de
referencia (color amarillo) y la que hay que alinear (color rojo).

Pulsa el botén Cambiar (Swap) si quieres invertir los roles de las capas. La capa que se considera
como lade referencia seréd la que habra que alinear y viceversa.

Pulsando el botdn OK, continuaras con la alineacion de las capas.

Seleccién de puntos en la capa a alinear: en esta ventana se pueden orientar las nubes de puntos
para hacer mas sencilla la alineacién de los puntos.

A continuacion, selecciona al menos cuatro puntos de una de las nubes de puntos en la capa
que quieres alinear. Al estar solapadas, se recomienda desmarcar la casilla “Mostrar nube de
referencia” para ocultarlay asi poder seleccionar mejor los puntos.

Para seleccionar un punto de la nube, haz clic sobre el que quieras seleccionar. En caso de que
quieras deseleccionar algiin punto, pulsa sobre el botén marcado con una X a la derecha de las
coordenadas del punto.

Los puntos van acompafados de una letra'y un nimero. La letra “A” indica que es un punto
perteneciente a la capa que se quiere alinear y el nimero indica el orden en que fueron
seleccionados los puntos.

¥2.6.0164 bis] - [30 View 2]

o+ M4z
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Reconstruccion de la nube de puntos con CloudCompare

Seleccion de puntos en la capa de referencia: una vez se han seleccionado los puntos de la capa
que quieres alinear con la capa de referencia, selecciona los puntos correspondientes estos pero
en la capa de referencia.

Para seleccionar los puntos en la capa de referencia conviene ocultar la otra capa, es probable
que haya que mostrarla de vez en cuando para recordar donde se habian situado los puntos en
esa capa.

El orden en que se seleccionan los puntos es muy importante, selecciona los puntos en el mismo
orden. Para obtener buenos resultados es importante asegurar que se seleccionan puntos muy
similares en ambas capas.

Aligual que en la otra capa, los puntos seleccionados van acompafados de una letray un nimero.
La letra “R” indica que es un punto perteneciente a la capa de referenciay el nimero indica el
orden en que han sido seleccionados.

Una vez seleccionados los puntos en ambas capas, pulsa el botén Confirmar, representado por
un tick verde.

260 [64 bits] - [3D View 2]

& @ 1 Clod

P

P¥® 4z

Informacién de la alineacién: aparece una ventana emergente con informacion sobre el proceso
de alineacién de las nubes. Para continuar, pulsa el botdn OK.

Align info

Final RMS: 1.2971

0.986 -0.166 0.033 -7.254
0.165 0.986 0.012 25.176
-0.035 -0.007 0.999 -0.829
0.000 0.000 0.000 1.000

Visualizacién del resultado de alineacién: a simple vista se observa que la nube de puntos
resultante de la alineacion es mas densa, y por lo tanto, el resultado de reconstruccion es mas
preciso.

108 %2  Cloud (1,69 M = 100.00% of pants coukd b Losded)
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Reconstruccion de la nube de puntos con CloudCompare

Unir nubes de puntos: si bien las nubes estan alineadas, alin no estan unidas. Para unir ambas
nubes es necesario seleccionarlas y después pulsar en: Editar > Unir (Edit > Merge).

De esta manera ya se pueden calcular las normales y reconstruir el objeto, tal y como se explicd
anteriormente.

Imprimir resultados de la reconstruccion

Existe uninconveniente ala hora de procesar nubes de puntos en CloudCompare: por lo general,
no cierralos objetos. En el ejemplo del totem, una vez reconstruidas la parte superior y la inferior,
estan abiertasy el objeto es hueco por dentro.

Este inconveniente puede causar problemas a la hora de imprimir el modelo 3D, ya que el
programa podria reconocer el objeto como un cilindro hueco e imprimiria sélo las paredes.

A continuacion se explica, para el software de laminado e impresién Cura, como solucionar este
inconveniente.

Ejecutar Cura: esta es la ventana principal que muestra el programa Cura. Consta de un menu
situado en la parte superior, un panel con cuatro pestafas en el lateral izquierdo y un visualizador
3D que ocupa la mayor parte de la ventana.

a-15.021 -
Expert Help
o B . . B

Abrir modelo 3D: para abrir un modelo 3D, pulsa sobre la pestana Archivo > Abrir modelo desde
archivo... (File > Load model file...)



H O R U S ‘ GUIA DE POST-PROCESADO DE LA NUBE DE PUNTOS

Reconstruccion de la nube de puntos con CloudCompare

Cura-15.02.1
Fis Tools Mickins Expert Hilp
Gcode

2 =i E . .

Ventana Abrir modelo: en esta ventana puedes navegar por los directorios y seleccionar el
modelo 3D quieres imprimir.

Una vez seleccionado, pulsa el botén Abrir (Open).

‘Open 30 modet

3] [ et OO

AL (519 b e b bmge 3 pege® png: 5 o)

Concel | Open

Visualizacién del modelo: una vez abierto, el modelo 3D aparece en el visualizador 3D del

programa. Puedes cambiar la orientacién manteniendo pulsado el botén derecho del ratény el
zoom con ayuda de larueda del raton.

Desde esta vista puedes observar que nuestro modelo 3D es hueco.

Cura-15.02.0
File Tools Machine Expert Help
s | Advanced | Pugins | Stan/EnchGCode

o ag K

e oz ol

Fn
Ettom/Top thckness (mm) 0.6
Pl Doty (%) i

‘Speed and Temperature

Prit speed (mmis)

© s
]

Supgort type Ererpnbers

Platform adhesion type  None

Filament
Diameter () 178
Flow 02) 1000

Visualizacién de las capas de impresion: en ocasiones, Cura detecta los objetos huecos y los
rellena de manera automatica. En caso de que la reconstruccién del objeto haya dejado puntos
en el interior del modelo, este no sera rellenado de manera automatica.

La mejor manera de ver si el modelo se va a imprimir correctamente es cambiando la vista al
modo Capas (Layers), donde puedes ver las capas tal y como las imprimira la impresora.

28
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StartfEnd GCode

Laminacidn incorrecta: para comprobar si Cura ha rellenado o no de manera automatica el
modelo cambia la vista al modo Capas.

La barra de desplazamiento situada a la derecha representa la vista del nimero de capas.
Deslizando la barra puedes ver mas o menos capas.

Para realizar la comprobacién del relleno del objeto lo ideal es situarse en una capa de
entremedias del modelo. El programa puede tardar en procesar las capas. Si cuando termine
de procesar, el modelo se muestra hueco es porque no lo ha rellenado de manera automatica.
Si, por el contrario, muestra una malla en el interior del modelo significa que ha rellenado
automaticamente el modelo y puede proceder a su impresion.

En laimagen de la izquierda se muestra el laminado de un modelo que no ha sido rellenado
automéaticamente por el programa.

HEa &

Configuracion Experta: para solucionar el problema del relleno del modelo, abre la ventana de
Configuracion Experta.

Para abrir esta ventana pulsa sobre la pestafa Experto > Abrir opciones expertas (Expert > Open
Expert Settings).

En el Ultimo apartado (Fix horrible), por defecto, solo viene marcada la casilla Combinar todo
(Tipo-A), Combine everything (Type-A), para rellenar el modelo por completo también tienes que
marcar la casilla Combinar todo (Tipo-B), Combine everything (Type-B).

Unavez marcada, pulsa el botdon OK.
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Una vez generado el archivo
de impresion (GCode) es =
importante volver a abrir

la Configuracion expertay
revertir los cambios que se
han hecho. De no hacerlo, es
posible que en laminaciones
posteriores aparezcan errores
y rellenos en lugares que no
deben aparecer.

Laminacién correcta: para comprobar que los cambios que se han hecho en la Configuracién
Experta resuelven el problema del relleno del modelo, visualiza una de las capas intermedias tal
y como se hizo anteriormente.

Enlaimagen de laizquierda se muestra el modelo perfectamente relleno vy listo para imprimir.

aEa &

Menu de guardado: por Ultimo, para guardar el archivo de impresién (GCode) pulsa sobre la
pestana Archivo > Guardar GCode... (File > Save GCode...).

15021

2]

il
19 Gy
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Reconstruccion de la nube de puntos con CloudCompare

Ventana de guardado: tras pulsar la pestana, aparece la ventana de guardado. En esta ventana
puedes navegar hasta el directorio donde quieres guardar el archivo.

Una vez puesto el nombre del archivo y elegido el directorio donde lo quieres guardar pulsa el
botén Guardar (Save).

Save tosipatn

[ P
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